Bad Stepper Motor [issue]

  • I just purchased an EleksMaker Draw and just got it assembled and am having 1 very big problem with it that doesn't seem to common. The X axis labeled stepper motor I received must be a bad stepper motor because it will cutout and skip steps. Why I think it's the stepper motors fault (what I've tried) is...

    -It will work 80% of the run time it is supposed to but when it cuts out the whole picture is off.
    -I tried swapping the X and Y connection points to see if it was the controller or software, the problem existed again only in that motor despite the inverted axis.
    -You can see it physically stop moving while the Y side goes on as normal, in this time the timing belt will be dragged over its teeth, so you can hear it too.
    -I double checked all pins, teeth and the belt are tight

    If there is something else someone would recommend I do/ try I will gladly, If this is the motors fault which I am fairly certain it is can I get It swapped out for free as a defected part or do I have to pay for another one?

  • Developer of T2Laser Software

    @mazlow See if it works disconnected from the belt, put a piece of tape on the shaft so you can see it moving. You could also swap the motors, that way if it's the mechanism the problem will stay on the same axis but if it's the motor the problem will move to the Y-axis.

  • This post is deleted!

  • @Zax Ok so I tried that, and I saw the same thing happen where it should have been moving but tape stayed locked in place for a few steps. Do you know anything else I can try?

  • Developer of T2Laser Software

    You ruled out the most common problem (mechanical) so now you should unplug the motor from the controller and see if it turns easily by hand - if it does, the problem is the driver. You can check the current limit with a volt meter or replace it (they are very cheap).

    Also check the cables, in case there's any damage or poor connection.

  • @Zax Ok so interesting new information found by this only a few degrees of the motor does it become extremely difficult to move it by hand even without power to it. When I put it back into the belt system its mistakes are uniformly affected. This can even be seen in the drawings I test ran where it make the same mistake almost exactly twice between two different runs. It looks like it is a problem is with the mechanical internals of the motor. Can this be taken apart and fix for a case like this?

  • Developer of T2Laser Software

    @mazlow It's possible, but these are very cheap motors ($10 or less) so I would just replace it.

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.