Gcode doesn't send Z-axis commands



  • I suspect that I'm missing something very simple but I can't get the gcode to include any z-axis commands. I'm using an Elelsmill. Ver 1.1e grbl. The axis works fine and I've tested everything using USG sender.
    I only need to engrave(no laser) text so I'm using the Sketch editor of T2Laser to generate the image.
    I can't find any settings for depth of cut and also in my settings menu I can't put in a value for Z-axis feed rate. Maybe that's not related.
    I'm totally new to cnc. I only started yesterday! Thanks in advance for any help.


  • Developer of T2Laser Software

    @jazzplayermark It is really simple, click the CNC Mode option in the menu. You will be asked to enter the Z-depth (maximum) and then the G-code will be correct. There's a quick guide for CNC on my website which may help. I just tried entering a Z feed rate without CNC mode being enabled and that does work, obviously it won't do anything as no Z commands are generated but you can still set the value.

    FYI: you will get a faster response by emailing me but I am also happy to answer on the forum as it may help others later.



  • Thank you for the very fast response! I did have CNC mode checked but didn't see the option until I unchecked it and then selected it again. I'm sure I just missed it when I first selected it. I think it's all working correctly. Nice software!


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.