GCode will not generate from T2Laser

  • When I send to device, the GCode generation pauses at 24% to 29% and then asks if I want to save the code.
    I get this in the T2Controller top panel:

    ( Generated by T2Laser )
    ( Image2Gcode for Grbl )
    ( Start Point: LL )
    ( Frame Mode : Abs. )
    ( X Maximum : 198.2 )
    ( Y Maximum : 280.4 )
    ( Laser Max : 5 )
    ( Feed Rate : 3000 )
    ( Resolution : 0.2 )
    ( Image Name : Hairline Diamonds to laser.jpg )
    M03 S5
    M03 S0
    G00 X0 Y0

    And this in the bottom panel:

    Total Lines: 18
    GCode Lines: 8
    Estimated Time: 0 second
    Total Distance: 0mm (c0/r0)

    And obviously there is nothing there to etch.
    I have had this issue today, whereas yesterday I was etching normally, well burning leather, but its a learning curve.

    I have just noted that when it stops generating the gcode it says 18lines and done.

    Can anyone offer help, thanks

  • Developer of T2Laser Software

    @hw-in-bda It sounds like something is corrupt, most likely a setting. The easiest solution would be to remove T2Laser and reinstall, take a look at the support section on my webpage and there's instructions (copied below).

    Upgrade error or to completely remove T2Laser:
    Go to C:\Users[username]\AppData\Local\Apps\2.0 and delete the sub folders but leave the 2.0 folder (change [username] to your user name).

  • Thank you Zax, I am currently etching with Elekscam, so will wait until that's finished, as it is soooo much quicker on T2Laser.
    I am impressed by your speed of reply and input.

  • I have tried that Zax, and unfortunately got the same error.

    I tried to reinstall and my system reports an error occurred trying to download 'https://t2laser.blob.core.windows.net/install/T2Laser.application'.

    Sorry to be a pain.

  • Developer of T2Laser Software

    @hwinuk So you deleted that folder, completely removing T2Laser - correct?

    Now when you try to install from my secure server https://t2laser.blob.core.windows.net/install/setup.exe you're getting an error? What is the error, is it blocked by your security settings perhaps?

  • I have managed to reinstal T2Laser, but after a couple of percent generating GCode it is showing T2Laser as 'not responding' and giving the 18 lines of code as mentioned before.

    Something does seem less than compatible, but its hard to see what, when the program has generated gcode previously and will allow me to use these.

    Elekscam is working, but slow and no where near as finessed, unfortunately.


  • Developer of T2Laser Software

    @hwinuk If you completely removed T2Laser and reinstalled, that would have removed any incorrect settings and also fixed any corrupt dot net files. If you still aren't getting the G-code I don't think you removed T2Laser completely. You must delete all sub folders under the 2.0 directory, that ensures all settings are removed. I'm not sure what is corrupt but something.

  • @Zax
    Hi Zax, thank you for that, but I did certainly remove the folders mentioned.
    I will try again, tomorrow.
    Best regards

  • Developer of T2Laser Software

    @hwinuk If you delete those folders and reinstall, click one of my sample files in the Help menu and see if the G-code is correct. If not, email or post the G-code and I will be able to tell what's going on.

  • @Zax
    Thank you,

  • Thank you Zax for the help and through the support email. its working now, after you said to keep laser minimum to 0 and to set laser max where I need it for the material.
    No wonder you get so many Kudos votes, I am so pleased that @Grant-B recommended T2Laser.

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.