Mac&EleksDraw: Univesal GCode Sender

  • Hello!

    I got my EleksDraw a couple of weeks ago, and I'm trying to make it work from my Mac. It's still not working, but it wiggles. Seems we're close to somewhere :D

    Here's what I've done:

    1. Download and install CH341SER_MAC.
    2. Download and install Univesal G-Code Sender
    3. From UGS, select Machine/Setup wizard to connect to the EleksDraw. UGS displays: "Connected to Grbl 0.9i". Youhou!! \o/
    4. Next step, "Import settings". I don't have any settings file to import, so I click "Next"
    5. "Motor wiring": There's a series of buttons which are supposed to make the servos move by steps. However, they don't. Pushing the X- or X+ buttons, or any other, just makes the servos produce a short sound, and that's all. Too bad... In UGS's console I see that the commands being sent are: "G21G91G1X0.1F100" and "G90 G21", they are followed by "ok" and "ok" again.
    6. I push "Cancel" in the setup wizard. Despite the failure to move the servos, UGS seems to be connected to the EleksDraw.
    7. I generated a simple G-Code for a polygon in Inkscape and loaded it using "File/Open Gcode File". Click "Play", and... IT MOVES!! \o/

    For the moment, the best case is when the plotter actually moves, however:

    1. I haven't managed to get the pen go up and down...
    2. The most frequent case is that I can't make the plotter move. I get, for example, "An error was detected while sending 'G1Z0': error: Undefined feed rate. Streaming has been paused". It seems that the codes sent by UGS are not compatible with the EleksDraw. Whereas the Gcode from inkscape gets the movement right, the buttons in UGS just fail...

    I'd love to know about some other Mac user's experiences!

  • I sent "A1" as gcode and now the up/down pen servo works! \o/

  • More information: I'm able to draw now, but the drawings are mirrored, rotated 45º (I'll go read the posts that talk about that), and the position drifts.

    Here's an example of the drift:

    I drew a series of concentric circles in inkscape, with a few radius lines. It looks like this:

    ![0_1559234977668_circle.png](Uploading 100%)

    I converted the file to gcode using the inkscape plugin. Now, this is how it's plotted:

    ![0_1559235105965_circle-eleksdraw.jpg](Uploading 100%)

    The first circle (outside) is not too bad, after that a straight line is draw, and after that the remaining circles do not close properly. The misalignment becomes evident at the center of the circle, where the lines do not cross at the center.

    What can be the error? I'm uploading the gcode, in case someone would be willing to give it a try in their own plotter.

    [](Uploading 100%)

    Thank you !

  • hmm... it seems i can't upload pictures or files. Here's a link to the svg, screenshot and gcode (.nc) in google drive:

    thank you for your help!

  • Developer of T2Laser Software

    @r03ert0 It sounds like your firmware is still not set correctly, the eleksdraw is a corexy system. Are you not able to use a Window virtual machine? Then you could use my T2Laser and you'll find the results are much better and so much easier to use. It's a single program to do all this and much more.

  • Thank you @Zax! T2Laser looks awesome. In any case, I need to update the firmware, right? To Grbl 1.1?

  • Developer of T2Laser Software

    @r03ert0 No. You are using the correct firmware (Grbl 0.9i) as that's what supports both servo and CoreXY. Unlike many programs that only work with one Grbl, T2Laser works with any version.

  • Thanks @Zax : )

    I sent a 'C1' code to the plotter to switch to CoreXY mode, loosened some screws, tightened the belt a tiny bit, and now the results are lovely! I've also been using some javascript code to control the plotter, and it looks promising :D

    I'll post some pictures later.

  • @r03ert0 any luck? I am setting up today and would like to use Mac.

  • r03ert0

    Thank you so much for your postings. I got a similar drawing machine, and there were no instructions to be found about the A1 and C1 code. I just typed that and it solved everything!

    During my research I did find that probably you don't need the CH34ser drivers as the newest macs come with it from apple, it may even cause some conflict. Read more here ( I would recommend to just trying without manually installing the drivers first.

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.