Intermittent stop laser stays on



  • I have an A3 2.5W setup. I have had it about a month and use T2. The first weekend I had it, I engraved various materials using different pictures and test samples and getting to know the program, capabilities, and terminology. I spent the majority of the day and had great luck, 10-12 different patterns. I have not used it since until last night. Using the same patterns and settings, when I hit start, the laser takes off for just a few lines of code the stops randomly, like it is paused, but laser on. After failure with the patters I had been using, I tried all three squares from the samples. On each different square the laser moved from home to the upper left, laser came on, began engraving, across top, down right side, across bottom and stops with laser on. I tried reloading firmware 1.1e and 1.1f and it says error, but then shows the proper one is loaded when reconnecting laser. I also tried using Laser GBRL to control, although I am not familiar with it, and the machine did the same thing. Any help appreciated. I looked through previous posts and could not find anyone with the same issue.


  • Developer of T2Laser Software

    @cmenke Do you get an "error" in the message box?

    If so this probably means the Nano has failed, usually a memory fault from over heating (based on many user reports the one used on the Mana board is very poor quality and unreliable).

    It could also be a USB cable issue or electrical noise from the motors (check for loose wires).

    You can also try enabling Simple Streaming mode, it may improve but is only a band-aid and not a solution. This uses less memory and processor on the Nano so it can work longer without failing. This is used as a test method, then replace the Nano with a better quality one such as HiLetGo, Geekcreit or Sainsmart.



  • Thank you for the response. I tried again this morning and all functioned fine for awhile. I made three complete test then failed on the fourth. I unplugged everything and walked away for about 30 minutes. After that I hooked all back up and it again worked for 2 test then failed. When it stops the window on T2 only says "sending" and nothing else. The last stoppage was 55%, and the others were around 75%. I then have to hit emergency stop to get out of the window. Using 1.1e and I wait to hit send until window says ready. Note the first stop today was on the smallest square from samples. It made 3 sides then locked. The last stop was on the grey-scale sample and it was through with the percentages and on the shades of grey. I would guess it had be running for 3 minutes or so. Again thank you for your help.


  • Developer of T2Laser Software

    @cmenke It does sound like the Nano is failing but it's odd you aren't getting an error. Did you test using SImple Streaming to see if it works longer?



  • I did try Simple Streaming and it did not help. I did however get "unable to process message status" in the window under "sending" just now. Could ambient temperature cause an intermittent problem? Its around 92 degrees in the shop.


  • Developer of T2Laser Software

    @cmenke That means a status message coming from the laser was corrupt, so it sounds like you have a communications issue more than an over heating problem but I can't be sure. Electrical noise (even from the motors themselves or something else nearby) can cause problems if you have a low quality USB cable. Usually if it's a memory issue on the Nano using Simple Streaming will make it improve so that's another reason to think the problem is something else.



  • Thank you. The USB is the one that came with it. I'll try another.


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.