Stepper Motors aren't working.

  • My EleksDraw arrived yesterday and I've just built the machine today.

    I've got the software installed, but when I go to use the machine, the pen holder will not move along either the X or Y axis.
    If I send a drawing to the plotter, the servo to lift the pen up and down works, but there is no X or Y movement.
    The manual X and Y controls don't do anything, either.

    Any help would be greatly appreciated.

  • Developer of T2Laser Software

    @KyleMC Are you sure the power supply is working?

  • Thanks for the suggestion. That is something I had overlooked.

    I've tested the included power supply on other devices, and the power supply seems to work fine.
    I've also tested other 12v power supplies on my EleksDraw, and I'm getting the same results - servo is working fine, no X/Y movement whatsoever.

  • Developer of T2Laser Software

    @KyleMC It is very odd that both motors do not work, the only common items are the power supply and Nano. We know these are both working so the problem must be software, does it do the same thing with my T2Laser program?

  • Success!

    With the T2Laser software, the steppers are working when I use the control buttons!
    That tells me the problem likely isn't hardware related.

    Now I just gotta figure out why EleksCam isn't working.

    Thank you so much.

  • @KyleMC

    Actually, despite being only a trial version, T2Laser isn't all that limiting.
    I may just try giving this software a go.
    It's nice when a program focuses on functionality over fancy graphics and unnecessary window draw animations.

  • Developer of T2Laser Software

    @KyleMC I wrote T2Laser for my own use, it's very stable and functional (it just works) but no I didn't bother with fancy graphics or animations as I use it in a production environment to run multiple machines (diode lasers, CO2 laser and CNC).

    It looks simple but it has many advanced features not found on other software such as rotary support, wood grain compensation and DXF optimization.

    Most importantly it is fully supported and constantly being refined.

  • @Zax I may have spoken too soon.

    I powered down my computer and EleksDraw after sending that last message.
    Upon restarting my computer, I can no longer control the XY (or anything else) with T2Laser.
    The EleksCam software still allows control over the servo, but no XY movement.

    Looks like I'm back where I started.

  • Developer of T2Laser Software

    @KyleMC Are you getting the Grbl Ready message? If not you have the wrong COM port or baud rate selected.

    Note: Make sure you don't have EleksCAM running as it will lock the port, I also believe it doesn't release the port when you close it (bad program) so after a reboot just test with T2Laser.

  • I'm not seeing "Grbl Ready" popping up anywhere after connecting.
    Where should I be looking?

    You were right about EleksCam locking the port, even after shutdown.
    I've restarted my computer and opened T2Laser, set the baud to 115,200, selected my COM port, and hit connect.
    (I've repeated this step for 6 separate USB ports, to make sure a bad port wasn't the issue)

    The X and Y controls do nothing.
    But now the 'Laser On' button will move the servo down, and the 'Laser Pulse' will move it down and back up. (That doesn't happen if I run EleksCam first.)

    After that, I poked around settings, I've gone to "Configure EleksMana" and selected "EleksDraw (E2)" to see if that would change anything. It didn't.

  • Developer of T2Laser Software

    @KyleMC You should see 2 messages, Connected COMx @ 115200 and then Grbl Ready. Since the servo is working you are connected OK, if the motors aren't working it sounds like you don't have power. Check the power supply and on/off switch.

  • Hello.

    I just had another look. It's right there in the bottom window.

    Connected COM6 115200
    Grbl Ready

    I've re-checked the power supply, and it's still working on other devices.
    I've also tried out a few other 12v 2A power supplies, with no luck.

    I'm guessing the on/off switch is the round button beside the port where the power supply goes? (the only other button or switch I've found on the board is under the USB connector)
    The blue light on D4 is on, and it stays on no matter how many times I press the button.

  • Sorry for this wall of posts begging for help from you.

    I just had a really close look at the control board, and I'm seeing some charring between pins and along a few traces on the Y stepper control board.
    I think I should break out my multimeter and possibly order a new stepper controller before pestering you further.

    Thank you so much for all the help.

  • Developer of T2Laser Software

    @KyleMC The Nano is powered from your USB port so it will operate and connect but the signals it sends to the motor drivers won't do any good if the board doesn't have power. If you have a volt meter check the laser connector + to - and it should be 12VDC, if not, your controller board has a problem. It could be a bad switch or input capacitor if the power supply itself is working.

  • I've swapped out the control board, and now it's working with both pieces of software.

    Thank you so much for all the assistance getting this setup.


  • Developer of T2Laser Software

    @Daniel-Hmid Hello Daniel :thumbsup:

  • @Zax Me 😆

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.