Eleksdraw is not working..

  • Hi..
    I set up y Eleksdraw and it worked fine for some time.
    Later I changed the Acceleration to 500 and pulse to 250. The motors slightly moved and stopped working.
    I tried to update the software but i;m getting Port not detected error.
    Not able to Rst Rom also.
    Elekscam is always showing "Find Serial Port failed. Please make sure you have already connected the Eleksmaker CNC deivce..."

    I tried to update the Software via EleksROM but it is of no use..
    The Eleksrom is uploading the code though I select any random port.

    What is the solution...?
    If I want to use Arduino Nano, how can I upload your firmware into the Nano?

  • Developer of T2Laser Software

    @intruder The "Nano" on the Eleks board uses a Chinese clone rather than a genuine Atmel chipset so it's fairly common for the EEPROM to be corrupted when changing parameters or firmware. Just replace the Nano and upload the Mana firmware, then configure for the EleksDraw machine. Very easy!



  • @Zax Yes... I tried all these steps..
    I got "Firmware reported error (1/1)"
    stk500_sync(..),........ error..
    How to solve thois?
    Con u provide the software that can be customized?

  • @intruder but did you replace the Nano?

  • Developer of T2Laser Software

    @intruder I'm telling you how to load a replacement Nano.

  • @marco_b yes.
    With Nano I tried all these steps..
    Why T2 Laser and EleksRom are not able to flash the code? And throws stk500_getsync error?
    Any chance I can get the sample code,?

  • @Zax Correct..

    I'm telling that there's an error while flashing which is stk500_getsync() ... with both your controller and Nano...

    Any solution?

    I wrote a simple code in Nano and tried to flash.. I got succeeded and able to rotate motors... Only T2 Laser and EleksRom are not able to flash..
    Hence if u could provide a sample or raw code, it will be helpful

  • Developer of T2Laser Software

    @intruder If you are able to upload via Arduino IDE you can load the Grbl firmware. All other software uses AVRDude to program the Nano, the message means the boot loader did not communicate correctly. In T2Laser you can enable Nano+ mode and try different baud rates.

  • @Zax any reply?

  • Developer of T2Laser Software

    @intruder I replied above. If you are able to upload sketches from Arduino IDE via USB then the boot loader must be working, but depending what firmware you loaded it may not be the default so using Nano+ and trying different baud rates is all I can suggest. You can also install Grbl from Arudino IDE the same way you load a sketch.

  • @Zax Yup..
    I tried..
    After multiple attempts... It is working fine...

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.