Laser Power Always Overridden



  • Hello
    Since yesterday I have this problem:

    No matter how i configure the Settings, as soon as i start the cutting the Laserpower is overridden to 100%

    Why?
    How can i undo this?

    I am using:
    1.1e

    Thanks in advance


  • Developer of T2Laser Software

    @JeneStar What do you mean? 100% would be normal power. It sounds like you are just seeing that real time overrides are available, that's correct for my default firmware.



  • thanks for the fast reply.

    Its like this:
    In the main Screen you I can decide what is the minimum and the maximum power of the laser. So I tell him 0% min 20% max.

    Then i head over to the "Controll Laser" screen and start the engraving/cutting. but as soon as the machine starts, there is displayed on the right side: override Laser power: 100%
    And it is fireing with 100% because i can manualy crank it down again untill he fires those 20% (which leafs a diffrent mark)


  • Developer of T2Laser Software

    @JeneStar 100% override power simply means it's at whatever you set in the G-code. I'm not really understanding what you mean by 0% and 20% max, on the design screen you typically set laser min to 0 and laser max to 255 (using my firmware and parameters), where 255 is max power.

    If you need to reduce the power to 10% you could set laser max to 25 but then you won't get much grey scale as you are only using the lowest 10% of available power and have very little variation. It would still show the override at 100%, which is normal as it's using the set values and not overriding them. It would need to show override of 1000% (not possible) to be running at full power.



  • I think i see my mistake.

    ( In the old Version i had to set the Laserpower between 0 and 1000. So now as i have updatet the firmware my 20% (200 laserpower) ment 78.4% for the new Version)

    Ill check it at thursday.

    Many thanks.


  • Developer of T2Laser Software

    @JeneStar T2Laser has always used 0-255 for laser power, you were probably using some other firmware previously. You can change the laser max Grbl parameter ($30) to 1000 if you prefer 0-1000 for power.

    The Nano PWM output (TTL signal to the laser) is 8-bit, so it can only do 0-255. Firmware that is set to 0-1000 requires Grbl to down scale the input values to determine the output, so 500 would be (500/1000) * 255 = 128 (rounded). The problem with this approach is the rounding and down scaling can cause banding effects in the grey scale rather than the smooth transitions T2Laser achieves. This is worse with CO2 lasers and CNC machines where it affects the cut depth.


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.