Diagonal movement



  • Hello everyone,
    I am struggling with the diagonal movement problem for Eleksdraw, that I have seen mentioned a few times in the forum.
    Thing is every time I reset the drivers, the machine functions correctly for one task ans then reverts back to diagonal movement. It stays like that until I flash it again
    I have tried both Elekscam and T2Laser with similar disappointing results.
    Any help appreciated.


  • Developer of T2Laser Software

    @Nassim-Dehouche T2Laser works perfect with the EleksDraw, perhaps you are resetting the Nano or uploading firmware which clears the settings?

    The diagonal movement is because Grbl has been switched to the default Cartesian mode and the EleksDraw is the less common CoreXY. This can be switched easily in the menu but once changed on your machine it will stay like that.

    0_1572869595687_t2laser_eleks_menu.jpg



  • @Zax thank you for your reply. I did precisely what you mention in your screenshot, as well as initially flah the nano with Grbl 0.9 for Eleksmana to no avail.

    Also, as mentioned in my post, the Eleksdraw worked perfectly fine at first (no diagonal movement) with EleksCAM but then it reverted back to diagonal movement in the middle of a drawing. So Inknow that the initial Grbl setting was correct.

    This behavior repeats every time I flash the controller again (install driver and select machine Eleksdraw): regular CoreXY movement then it reverts back to diagonal movement.


  • Developer of T2Laser Software

    @Nassim-Dehouche If the firmware is not the issue then you may have a mechanical problem, if one of the motors stalls (loses steps) then it will begin moving diagonally. The stepper drivers have most torque when moving slowly and cool, if you are using higher feed rates and the drivers are heating up you may be losing torque and then friction takes over.



  • @Zax Thanks for these pointers Zax. Unfortunately, I have also ruled out any mechanical problem, since the issue gets fixed (temporarily) every time I flash the nano again and go through the installation process, until it reverts back to diagonal movement. This is really a head-scratcher.

    The higher feed rates suggestion is excellent. It may be something along these lines, since I let the machine cool down before making a new install, it may be just that. Will try to debug based on this. Thanks again. Your software and contributions to this forum are appreciated.


  • Developer of T2Laser Software

    @Nassim-Dehouche If you rule out a mechanical / electrical issue, I would recommend replacing the Nano with a better quality clone. The Eleks uses a non-Atmel chip which based on many user feedback experiences a lot of memory issues due to heat soak, so it may just be losing it's parameters (stored in EEPROM).

    I have used these clones with good success (Geekcreit, Hi Let Go and Sainsmart) but any that uses a genuine Atmel microcontroller should be fine.



  • @Zax double-checked all connections and as mentioned before it works "sometimes" so there is no electrical problem. I am not going to replace a brand new device I have just bought. Need an Eleksdraw representative to step in here. This is ridiculous.



  • I'm having the same issue. It's unfortunate that there is no additional replies!


  • Developer of T2Laser Software

    @NikonErik Firmware configuration is most likely, what precisely is it doing when you use left, right, up, down jog arrows?

    Do they all move diagonal, just in different directions?



  • I have the same problem with a A3 pro. How can i fix? when a click on E2 in T2Lases nothing happing.


  • Developer of T2Laser Software

    @paulo-victor Use my Grbl 1.1e DEFAULT firmware for all machines that use standard Cartesian coordinates.



  • @Zax i just try to use without update anything. But now i think is inoperable

    Yesterday i try to fix the diagonally problem with my A3 pro.
    I use the t2laser software like show in the forum.
    I try for 3 times and the machine no work properly. When i try one more time today, start show upload failed error on update de firmware. I think the arduino nano is bricked.

    I'm very disappointed. I bought the machine less than a year ago and waited for my vacation to test. I was unable to perform any tests. First the engines did not work, then the machine only worked diagonally and finally the nano is inoperable.
    Disappointed.


  • Developer of T2Laser Software

    @paulo-victor I don't know what instructions you followed, but using T2Laser with my Grbl 1.1e DEFAULT firmware always works on a standard Grbl based laser engraver. What exactly did you do? It is possible to reprogram the Nano (just need to reload the bootloader if it is "bricked") or you can get a replacement for $3.



  • how can i reload the bootloader? I used only t2laser fallow the instructions: https://forum.eleksmaker.com/topic/2996/diagonal-movement/13
    https://forum.eleksmaker.com/topic/2491/plotter-moving-on-diagonal

    and finally i tried to use de Grbl 1.1, the printer works x and y corretly, but the servo no work. The last try using t2laser show something like upload failed.
    If was a possibility to fix the bootloader, i want to try. Get a new nano is suppose to delivery just in 2021.


  • Developer of T2Laser Software

    @paulo-victor What machine do you have? You said it was an EleksMaker A3 Laser Engraver but now you say it has a servo so is it an EleksDraw like the instructions in that link?

    You can reload the boot loader using Arduino IDE and an AVR programmer, another device can be used too. There are many posts, blogs and videos on how to do this so.

    You can get a Nano clone from many places, depending on your country they may be available locally at a computer or electronics store or from local sellers on ebay, amazon etc.

    The only way you could corrupt the Nano is loading firmware that is not suitable for your machine or if you have a communications error during upload. If you have other software running (that is poorly coded) those programs can "lock" the port and do not release correctly when you exit so they can cause problems, you need to reboot to clear them. T2Laser does not have this bad behaviour, it releases the port and unloads the driver.



  • I did like you said and i fix the bootloader.
    When i bought, i leave the laser because a was a laser more strong. My laser is too big and dont work like i want. After that i bought the servo to put pencil.
    How i configure de A3 to work with the servo ?


  • Developer of T2Laser Software

    @paulo-victor If you have an A3 laser platform it is Cartesian coordinates, and then you replaced the laser module with a servo based Z-axis (this means a small hobby servo, correct?).

    Then you would use the 0.9i Eleks Mana firmware and select the C1 and A1 options, do this before you connect the servo or power to the machine - only with USB power. Then set laser max to 55 and it should work correctly.



  • ty worked like a charm!!!


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.