Diagonal movement

  • Hello everyone,
    I am struggling with the diagonal movement problem for Eleksdraw, that I have seen mentioned a few times in the forum.
    Thing is every time I reset the drivers, the machine functions correctly for one task ans then reverts back to diagonal movement. It stays like that until I flash it again
    I have tried both Elekscam and T2Laser with similar disappointing results.
    Any help appreciated.

  • Developer of T2Laser Software

    @Nassim-Dehouche T2Laser works perfect with the EleksDraw, perhaps you are resetting the Nano or uploading firmware which clears the settings?

    The diagonal movement is because Grbl has been switched to the default Cartesian mode and the EleksDraw is the less common CoreXY. This can be switched easily in the menu but once changed on your machine it will stay like that.


  • @Zax thank you for your reply. I did precisely what you mention in your screenshot, as well as initially flah the nano with Grbl 0.9 for Eleksmana to no avail.

    Also, as mentioned in my post, the Eleksdraw worked perfectly fine at first (no diagonal movement) with EleksCAM but then it reverted back to diagonal movement in the middle of a drawing. So Inknow that the initial Grbl setting was correct.

    This behavior repeats every time I flash the controller again (install driver and select machine Eleksdraw): regular CoreXY movement then it reverts back to diagonal movement.

  • Developer of T2Laser Software

    @Nassim-Dehouche If the firmware is not the issue then you may have a mechanical problem, if one of the motors stalls (loses steps) then it will begin moving diagonally. The stepper drivers have most torque when moving slowly and cool, if you are using higher feed rates and the drivers are heating up you may be losing torque and then friction takes over.

  • @Zax Thanks for these pointers Zax. Unfortunately, I have also ruled out any mechanical problem, since the issue gets fixed (temporarily) every time I flash the nano again and go through the installation process, until it reverts back to diagonal movement. This is really a head-scratcher.

    The higher feed rates suggestion is excellent. It may be something along these lines, since I let the machine cool down before making a new install, it may be just that. Will try to debug based on this. Thanks again. Your software and contributions to this forum are appreciated.

  • Developer of T2Laser Software

    @Nassim-Dehouche If you rule out a mechanical / electrical issue, I would recommend replacing the Nano with a better quality clone. The Eleks uses a non-Atmel chip which based on many user feedback experiences a lot of memory issues due to heat soak, so it may just be losing it's parameters (stored in EEPROM).

    I have used these clones with good success (Geekcreit, Hi Let Go and Sainsmart) but any that uses a genuine Atmel microcontroller should be fine.

  • @Zax double-checked all connections and as mentioned before it works "sometimes" so there is no electrical problem. I am not going to replace a brand new device I have just bought. Need an Eleksdraw representative to step in here. This is ridiculous.

  • I'm having the same issue. It's unfortunate that there is no additional replies!

  • Developer of T2Laser Software

    @NikonErik Firmware configuration is most likely, what precisely is it doing when you use left, right, up, down jog arrows?

    Do they all move diagonal, just in different directions?

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.