line skips or travel stops

  • I am using the Eleksmaker a3 with the t2 laser software. Fantastic program.
    i am running into a problem with the machine 1) skipping lines or 2) shifting lines or 3) stopping travel then it just burns back and forth on the same line over and over .
    i though it may be a problem with the belts sticking, but it does the same things when using diagonal engraving. so therefore it cant be just and x or y problem. it is then a x AND y problem at the same time.
    i have tried on 2 different computers using a security dongle.
    does anyone have any guesses at what could cause this problem

  • Developer of T2Laser Software

    It sounds like you have a backlash issue with the belts, but if you could post a picture that would help diagnose the problem.

    If that's the case, try slowing down the feed rate and/or testing reduced acceleration mode (found in the advanced settings on the laser control screen).

    These are workarounds but if it fixes the problem you know it's a mechanical issue that needs to be corrected.

  • ![alt text](0_1494784983538_Untitled-2.jpg image url)

  • Developer of T2Laser Software

    OK, so it's not backlash it's your motors losing steps.

    Steppers have lower torque at higher speed so like I said above, slowing down would probably show improvement.

    There are several possible causes.

    1. You may have too much friction, either belts are over tight or the wheels/bearings are sticking.

    2. Your motor current isn't sufficient.

    3. The power supply isn't able to provide enough power to the laser and motors - this is common on the 5W and higher lasers. They should have their own dedicated supply.

  • thanks for the suggestions
    will try checking belts, slowing down and upping the potentiometers
    it is a 2.5w model but i will look into a different powersupply

    i will update post with results

  • Developer of T2Laser Software

    2.5w and motors shouldn't be a problem, so just check the other items and you should get an improvement.

  • EleksMaker Customer Service

    @Zax said in line skips or travel stops:

    1. You may have too much friction, either belts are over tight or the wheels/bearings are sticking.
      try to loosen your belts and adjust the wheels, make sure they can be pushed by hand smoothly
    2. Your motor current isn't sufficient.
      switch the potentiometer clockwise on motor driver(no more than 1/4)

    Hope above helps.

  • slow and steady won for possible solutions.
    i have upped the potentiometer and lube the wheels, but this was as a preventative measure after completing a full error-free job with just slowing down

  • Active Member

    @crazycanuck hey canadian. do you mind if i ask how fast you were trying to burn that wasnt working and how fast worked?

  • @nottingham82 2000, needed a higher laser power to compensate for the speed.
    worked ok for smaller designs. problems started showing with larger pieces

  • @nottingham82 standar speed of 1000 worked fine for softwood, have varied laser power settings between 255 and 500,
    Overall slower is probably better for the machine anyway. less stress on belts and you can use a lower laser power at slower speeds, so the lifespan of the laser is probably going to be longer

  • Active Member

    hmmm that is interesting you saw a difference between 255 and 500. If you are using T2 firmware, everything above 255 is converted back down to 255 because 255 is max.There are other firmwares that use a max of 1000. 1000 or 255 doesnt matter so long as you know what the firmware max is. You dont get extra power by setting your max higher since the 8 bit processor can only handle 255 steps to max power. You may want to reflash your nano to ensure you dont get any thing weird happening.

  • @nottingham82 thanks for the heads up on the firmware

  • Developer of T2Laser Software

    The default max for Grbl firmware is 255, so if I compiled it (like the default Grbl 1.1e in T2Laser) that's what it will be but I believe the mana.hex from Eleks uses 1000. It's older so doesn't have several great features and the motion control isn't as good but if you want to use it for compatibility then set your laser max to 1000 in T2Laser.

  • @Zax Thanks. It is one of the eleks models so im sure the advice will help.

  • Developer of T2Laser Software

    If you haven't flashed the firmware it's probably got mana.hex loaded, which responds with Grbl 0.9j I believe.

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.