The drawing function does not start!



  • Hello, I just received my Eleksdraw three days ago, and I finished assembling it yesterday. I installed the Eleksmaker Evolution Desktop CAM 3.1 software and the connection with the robot is done (I use the online videos to adjust the settings).
    At this point I have a problem: when I launch a basic drawing (in the software), the data is sent to the Eleksdraw, but it does not move! There is only the arm of the pen which is lowered and raised, but the machine does not move a millimeter to follow the drawing: it is standing still!
    However, on the software, the lines of the drawing are colored green, as if it worked ...
    Another point that can be noted, when I stop the drawing and go to the "Control" tab, I can raise the pen (Laser ON / OFF) but also move the head with the arrows! So the movement is working well. But not in the drawing function ...
    I tried a lot of settings to find why it didn't work, watch several tutorials, but I can't find the solution ...!
    Can you help me please ? ...
    Thank you, have a good day,
    Dorian Etienne


  • Developer of T2Laser Software

    @dorian.etienne Test your machine with T2Laser (free trial), do not change any firmware or settings just select the COM port and connect to the machine.



  • Hi @Zax
    I downloaded T2Laser and contected the EleksDraw. It works but it's the same problem : I can move manually by the arrows and change UP/DOWN. It's the same on EleksCAM software, but it won't move when I start a draw ! What can I do to resolve this ?



  • Hi @Zax
    I have retested to launch a drawing from the T2 Laser application and it works! I don't know why it doesn't work with EleksCam. My problem now is that the T2 Laser software being a trial version, I cannot use it because it quits by itself after a very short time ... How to fix this?


  • Developer of T2Laser Software

    @dorian.etienne OK, so you know the machine works.

    T2Laser has many more features and also supports Grbl 1.1 which provides faster and smoother motion, real time overrides and dynamic laser power for better engravings. You can also enhance the machine with home switches, rotary axis and much more that is not otherwise possible.

    You can register a single computer for $39.95 or contact me for other options such as a USB "dongle" key if you need a portable license.



  • Ok thank you, I'll check this.
    Can you say I am having this problem on EleksCAM software? So maybe they can try to troubleshoot the software (for me and the others users). Thank you !


  • Developer of T2Laser Software

    @dorian.etienne That software is obsolete and no longer updated or maintained, if only supports the old Grbl 0.9 which was replaced years ago. You won't get the best performance from your machine using old firmware and software to control it.



  • Hello,

    i've had the same problem here. i'm using the eleksdraw pro with firmware 3.8 . I installed the t2 software , but there is still something wrong, it draws the text only diagonal and in mirror. settings eleksdraw E2.
    It could be some settings in the software...

    Greetings from belgium,

    Eddy Mathy


  • Developer of T2Laser Software

    @DigiEddy It is the firmware not configured correctly. If you follow my instructions it will work.

    If you have a CoreXY machine with servo (EleksDraw)

    1. Make sure you are using Eleks Mana firmware (Grbl 0.9i)
    2. Select EleksDraw from the Configure EleksMana menu

    If you have a Cartesian machine or other configuration let me know (picture of the machine) and I will tell you the correct set up.



  • @Zax Tnx a lot, it works now with the correct firmware. Due to the procces earlier, my servo died on me. I've already ordered a new one but this time with metal gears and will replacing the broken emax ES08AII with the emax ES08MAII.
    I hope the controller is ok. I was able to plot some test words without lifting the pen and it looks fine.


  • Developer of T2Laser Software

    @DigiEddy That is very common, which is why my instructions say to keep the servo disconnected during firmware setup and configuration. It is because the PWM output for laser causes over rotation and strips the plastic gears, when switched to servo mode the PWM output is reduced and won't cause damage.


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.