Axis move flawlessly but no servo action

  • Hey! I can't seem to configure it to e2 - a1 mode, when i press the option in the "configure Eleksmana" menu basically nothing happens appart from the max value of the laser in the right control menu, but turning laser on or off has no effect. What am I doing wrong?

  • Developer of T2Laser Software

    Do you have the EleksMana firmware loaded? (it's in the Custom Firmware menu, and will report Grbl Ready or in debug mode Grbl 0.9i).

    Do you see the command appear in the message window?

    Selecting E2 is sufficient, it sets C1 (CoreXY) and A1 (Servo).

    Are you sure the servo is connected correctly, not backwards?

  • Hey Zax!
    I don't think my servo is backward, considering elekscam works just right with my unit.Guess there's no reason why your software would need my servo reversed from elekscam, yeah?
    I did flash the 0.9i firmware, connecting to com port says GRBL ready, but then clicking anything in setting > configure eleks mana does no action, no message is shown after grbl ready.
    So basically, i get:

    Connected COM3 115200
    Grbl Ready

    and after that nothing. Ideas? If i get it to work, you're probably gonna get another license for it :)

  • Developer of T2Laser Software

    OK, if it works with EleksCAM then it should already be setup to work. No need to change firmware or settings.

    You don't have both software running at the same time or anything like that?

    If you manually turn the laser on/off with the power at 30, the servo doesn't do anything?

    It must be something really simple.

  • My servo does nothing and my axis moves in a diagonal and I am very quickly losing patience... Help!

  • Developer of T2Laser Software

    @Buck481 You need to setup the firmware for EleksDraw, in T2Laser after you've installed the correct firmware there's a sub menu called Configure EleksMana.



    There should be something similar in EleksCAM if you are using their software.

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.