ELEKS MILL - X-Axis stepper motor skips steps

  • Hi all,

    if I set up a milling with F360 and the mill starts to mill the part,
    all works fine except the X-axis. That one skips the steps, if the bit is forced a little.
    The Y-axis, which has the same speed and progress settings, will go thru the wood with ease.
    But when it comes to X-axis, the bit is not moving properly.


    1. could it be, that the stepper driver has not the correct voltage
    2. what is the correct voltage on the stepper driver (0,92V?)
    3. cool dit be, that the stepper itself has an issue

    Any suggestion/help is very much appreciated

    Thanks in advance

  • Developer of T2Laser Software

    If you are talking about the Vref for the stepper driver, 0.92V is too high as the driver is only rated for 1A without a heatsink and fan.

    It should be <0.8 Vref and usually ~0.3V for a single motor.

    Your lost steps may be due to friction, check that everything is moving freely. Are the output sizes correct? If not, you probably don't have the steps per mm setup and that will also cause these issues.

  • @Zax
    Hi thanks for your reply.
    The steps are correct, I set the firmware values accordingly.
    The size is exactly the defined one in the drawing.

    The only issue I actually have, is a problem with the linear bearing on X-axis, which will be replaced by ELEKS within the next 20 days.
    I will disassemble the part and see if this causes the issue. But I think, when I assembled it, there was no issue at all.
    If I run the code without drilling/milling the motions are ok, only if I put it down to wood, I get the prob.


  • Developer of T2Laser Software

    It sounds like the torque is insufficient. Try a slower feed rate as steppers lose torque as the speed increases. You might also want to reduce the acceleration values as that may help also.

    Did you use the mana.hex that Eleks provide and switch it to CNC mode?

  • @Zax I have the GRBL 0.9 at the moment and was going to try the 1.1e or what the latest version is.
    If I am honest, I got 2 3D printer and if I would try to stop the steppers by hand, I could not stop them, but those ELEKS MILL steppers are easy to stop...
    I wil check the Vref as soon as I get my meter back....

    The MANA.HEX was on and I updated that one first, before I tried GRBL

    By the way, I do appreciate your assistance....


Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.