So Disappointed

  • So Disappointed

    Just got it yesterday!! Even though there were parts missing I was able to get them at my local hardware store. The build was easy but I had to locate all the instructions on youtube. The eleksmaker site did not display videos properly in 4 different browsers on 3 different computers. SO I could not get any directions from them! Anyway I Installed the EleksCAM software on win10 creators and the software shows the splash screen and then disappears nothing after that. AS I am typing this I just heard a noise and smoke came out of the unit and the motors are just moving on their own. Removed power and reapplied it is just moving the motors and making noise...NOT HAPPY AT ALL

  • Active Member

    @MItchcecg said in So Disappointed:

    The eleksmaker site did not display videos properly in 4 different browsers on 3 different computers.

    Oh man that sucks that you tried all those different computers. The videos are not actually up yet. This site is still brand new! I think they added the videos tab like 2 weeks ago... or at least that's when I first noticed it. Putting their store up has occupied all their time. Maybe one day soon there will be videos there.

    Your other options for running an Eleksegg if cam wont run for you are T2Laser (its not free but it is free to try) or Inkscape with the gcode plug in to create g code then use universal gcode sender to send the code to the Eleksegg.

  •  nottingham82 thanks for the reply. Unfortunately after the unit was plugged in for about 15 minutes nothing sent to the unit just power, it made a funny noise so I looked at it and smoke was coming out and the motors were moving. now the new unit has a dead board and I have gotten no response from the point of purchase Bang Good about the issue

  • BTW for all that cares I just got this responce on the Bang Good site from HEEDAF
    "Return it - if you can! Banggood quit replying to me and PayPal said to return it but I had to pay shipping which was $36. It has never worked and Eleksmaker quit replying to anyones posts. I tried submitting a 1 star review but Banggood never posted it. I don't know why they are even selling it when they KNOW it doesn't work. "

  • am having similar problems with Banggod to the point I purchased a servo and steeper motor from amazon for my ELeksEgg just to prove the parts were bad that I had gotten in my original kit. to date I cannot create any image on the egg.
    I have asked for help and gotten none. they keep asking for more and more videos they wanted to see the connections I sent them photos they want video of connections WHY??? makes no sense. Anyway even after getting the unit working with my own purchased parts the thing does not work well enough to print on an egg I want to return it and get my money back or have a human from eleksmaker call me and solve the issues


    I received it with a bad servo and a bad stepper motor. Since Banggood was of little help I ordered both from amazon after replacing them all seemed to work but the pen up and down was reversed. I finally realized that I built the assembly backwards. Since I am an electronics Engineer and not a mechanical one I was looking for electrical problems (silly me ) anyway it is now working. I just should get replacement parts from Banggood for the defective ones that came with the unit.

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.