Help! Image upload fail, screens blank



  • I'm having the same issue blank screen and only managed to get it working again with the above mentioned tool. No bitmap support is a major downside (I want pixel perfect, not compression artifacts).

    The supplied images are not the same quality (worse). Check out the gallery images and compare. File properties of the exe don't match either (official exe has a product name).

    PS, mine also comes from banggood.

    PS 2, if this is an issue multiple people are having, why is there still no official reply from EleksMaker?



  • @Verodin I really thinking the banggood is a fake one or they changed some specs. For example, in the back side of the screens, you can see the lettering is different on the Elekstube name and it doesnt have some numbers as the promotion picture.



  • @JulioTavares From Banggood! They told me to ask how much the return postage is and to write to them! They told me to have it repaired locally and they would pay for the repair. Funny!



  • @JulioTavares Everything is fine for me. There is another version, also based on this hardware, which also handles Wifi. It's called NovelLife. Youtube Video



  • @Verodin This is a very good question! I think you need a full software update and they don't dare to do that because the ESP32 update is not that easy. I'm not right! I'm sending mine back, it was too expensive to not work properly. I'd rather buy a regular Nixie watch.



  • @VoiceMix-Master They said the same for me. Absurd. I want the full refund, but the shipping from Brazil to China is around U$50. I really dont know what to do.
    They updated their product page saying to remove the back rgb led from the last screen to stop this from happening. I dont want a butchered clock for that price...



  • I've considered sending it back as well, but same as you, it's not worth it. I'm taking my losses (it is a risk ordering stuff from sites like BG that are located on the other side of the world) and will bring my business elsewhere.

    There is another firmware that out there on GitHub that I plan on giving a go when I have the time; https://github.com/frankcohen/EleksTubeIPSHack
    Hopefully there are no hardware changes that require some reverse engineering. Who knows what other changes Geekcreit (BG's copycat partner) has done.



  • @JulioTavares:
    "For example, in the back side of the screens, you can see the lettering is different on the Elekstube name and it doesnt have some numbers as the promotion picture."

    Indeed! Thanks for pointing that out. Promo pics have copper letters, BG's version is silkscreen. Also did you notice the PCB of the screens has a different thickness in real life?

    edit: now that I'm checking my actual clock, I see that 2 of the 6 screens have a thinner PCB! And they tilt much more forward/backward when you move them.



  • 0_1629210179814_fake1.jpg 0_1629210190266_fake2.jpg



  • @JulioTavares I found working software and wrote to them to make a deal, but they told me to send it back. I should post it and they would transfer the postage immediately via PayPal. They sent me a document that I had to print out and put in the box. I am now preparing to post it. Postage from Hungary will not be cheap.



  • @Verodin It didn't work properly for me! Wifi worked, it started with a blue nixie display, but I couldn't set the wifi to the home network and I couldn't set the time. However, there is a WLED version, it is good! It worked perfectly, the wifi was a bit hectic, but at least it worked. Smoothly, I reprogrammed from Total Commander Command line with ESPTOOL and back again! I copied this from a forum post:

    So I wanted to run WLED firmware on my Elekstupe IPS clock.
    I'd played with the Elekstube Official App and changed the Custom font in the clock.
    This was a good place to start. It proved I could talk to the clock and provided me with the tools I required to change firmware.
    I also noticed in the Official App the COM port number (13 for me) I needed to use for communications with the clock.

    Once I'd installed the Elekstube Official App, I had a epstool directory.
    \IPS Upload Tool\esptool
    I'm going to refer to this as my "Working Directory"

    First off - I backed up my original firmware
    I made some mistakes along the way, but this backup go me up and running again every time.
    I went to a Command Prompt and my "Working Directory" then ran the following command
    NOTE: for me the Com Port was 13. Check the COM /CH340/ port in the Elekstube program.

    esptool --baud 115200 --port COM13 read_flash 0x0 0x400000 ORIGINAL-fw-backup-4M.bin (Check the COM /CH340/ port in the Elekstube program.)

    I used the following command to upload the ORIGINAL firmware, after my screwups.
    esptool --baud 115200 --port COM13 write_flash 0x0 ORIGINAL-fw-backup-4M.bin

    I got my WLED firmware from the zip file in this post.
    https://github.com/SmittyHalibut/EleksTubeHAX/issues/7#issuecomment-845762025
    I unzipped it into the "Working Directory".

    I uploaded the Bootloader and the Firmware using the two following commands. (In Total Commander Command Line or windows CMD.exe)

    esptool --baud 115200 --port COM13 write_flash 0x0 esp32_bootloader_new.bin (Check the COM /CH340/ port in the Elekstube program.)
    esptool --baud 115200 --port COM13 write_flash 0x10000 elekstube_ips.bin (Check the COM /CH340/ port in the Elekstube program.)

    After the reboot, Nothing appears on the Clock Display, this is expected.
    But the Clock does now have a Wi-Fi access point you can connect with.
    Once connected to SSID: WLED-AP P/W:wled1234 I completed the configuration of my new firmware.
    Configuration details are elsewhere and will likely change with firmware revisions, so I won't cover those here.

    Except to say, I used a browser to visit 192.168.1.2/edit (not really my clocks IP address)
    Using that menu I "Choose File" and "Upload" my 0-9 .bpm files (all ten files), I rebooted the clock and the clock display was up and running.

    I'm in no way an expert in this field, I post what I did in the hope that it points others in the correct direction with their firmware replacement journey.



  • @VoiceMix-Master

    That is excellent news, thanks a lot for taking the time to write it all down!

    Unfortunately I haven't had time to go any further with it. A baby is kind of killing any spare time I have left to work on this. I do plan on continuing, but it will be delayed to say the least.

    Thanks again for sharing your findings!



  • This post is deleted!


  • This post is deleted!


  • This post is deleted!


  • banggood also sent me the updated software and now the images are back, the problem was the old program that reads the bmp file and not the jpg as in the new one. Unfortunately i also have the seconds display after a few moments the image freezes or disappears, it sucks. There is no trace of this software around on the internet and I don't understand why. I hope it is not a fake offered by banggood, I contacted the manufacturer and they do not respond..you need to have a software and firmware update immediately



  • @VoiceMix-Master software link not working says file not found





  • @VoiceMix-Master

    Could u please re-share the new software



  • We have reviewed the 7 Best Miller Welding Helmet which offers you versatility, efficiency and balancing for the welding procedure. In the reviews, we have talked about each of the helmets with its precise detail. We have mentioned the technologies which are used in making these helmets such as ClearLight Lens technology, X-mode, automatic change of shades and many other things. We have enlisted the top 7 affordable helmets according to their specifications and specialty. Hence, you can save both time and money just by examining these reviews.


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.