Cant get the laser module to work in EleksCAM

  • Hi,
    I downloaded the EleksCAM 3.1 installed and started up.
    I installed the new firmware using RST ROM button and everything went good.
    I can move the laser around with the controlbuttons (X-,X+,Y+,Y-). So far so good
    If I turn on the laser it actually turns on (It didn't in the BenBox software so thats good).
    If I take a picture from the gallery and tries with theese settings
    Size 50 x 50 (I suppose this is mm)
    Speed: Its preset to 1000 when I choose EleksMill in the settings
    Realpoint, Each mm 6 line and Fold Line

    When I try to run this the laser goes on and it seems like it having av blast and burning some wood, but no stepper movement at all. None what so ever beside the first homing.

    Second thing.... The .1 mm dot that the laser should produce is more like 1mm

    How do I get this to work?

  • Active Member

    Depends on the laser as far as how to focus the laser. On the 5500 2500 and 1600 it has a focus knob just turn it till is as small as it can be. On the 500 you have to move it up and down to get it the right distance from the engraving to focus it.

  • Any thoughts why it don't move?

  • Active Member

    your windows regional settings are set to . and not , correct? with the system unplugged the gantry moves freely? get a hold of a cheap multimeter and check the voltages of the stepper drivers and that they are providing power to the stepper motors.

  • My reginal settings are Swedish and we use , and not the . (dot)
    I can use the controls from within EleksCAM and move all stepper motors arounf (not the Z but X and Y) are moving when I press the buttons

  • Active Member

    if you have a , elekscam wont work. You have to change your regional settings or use a different software.

  • That actually solved it. It works now. As a software developer myself I suggest that the EleksCAM developers (if they can't handle it in another way) just do a quick and dirty replace and change the ',' to a '.' in the gcode

  • Active Member

    This post is deleted!

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.