Problem with eleksegg

  • Just assembled my Eleksegg and 2 major problems.

    1. The X axis servo arm has no strength. When it rotates, the entire thing just flops over after the first or second left/right turn.

    2). My servo motor to lift the pen holder only goes up when I turn off the laser. However when On, it does not fall back down.

    Anyone got any suggestions?

  • Ok

    Problem 1: solved - only has strength when drawing

    Problem 2: Solved - change to servo mode

  • Take that back, Problem 1 still exists. The arm will rotate, then suddenly flop.

    Any ideas?

  • Developer of T2Laser Software

    @sumozebra If you are talking about the stepper motor (the only servo is for the pen up/down mechanism) then are you sure the set screw is located on the flat of the shaft?

  • @Zax

    The servo for the pen arm I got working no problem.

    However, the X axis stepper, it'll go left and right for a bit then suddenly the whole thing flops down, as if the stepper motor doesn't have the torque to keep the pen up.

    Please see youtube video:
    Youtube Video

    Youtube Video

  • Developer of T2Laser Software

    @sumozebra Do you mean when it isn't running?

    That's due to the firmware, it powers down the motor after a set time to prevent overheating the drivers. You can change it using $1 command, send $1=255 to keep the motors energized but if the driver current is set too high you will damage it.

  • @Zax heya, actually not only when power down. If I'm printing, it'll move the x axis arm left and right, but after it goes past an angle, it appears as if there's no strength and the arm just flops to one side and tried to keep drawing but of course it a completely wrong position / x axis arm is completely flat on the machine and only the servo moves.

    Please see video 1 in previous post for visual explanation.

  • Developer of T2Laser Software

    @sumozebra Have you set the motor driver current?

    The Vref should be ~0.35 VDC.

    Edit: After watching the video (and laughing at your drunk Egg machine) it looks like you may not have the firmware set properly or the software isn't controlling it correctly. I can't help with that as I don't use their software but perhaps they have a menu option to select Egg machine?

  • @Zax I'm not sure how to set the motor driver current.

    But yeh, as you see, it's pretty much EleksDrunkEgg for my machine, after a few wobbles he topples over =P

    What software do you use for controlling your Eleksegg? maybe stupid question since u're developer of T2Laser.

    Does T2Laser work with the EleksEgg / Draw / Mill? since those are the 3 machines that I use. If it's good, intuitive and user friendly and have active support, I'm more than happy to pay.


  • Developer of T2Laser Software

    @sumozebra I have posted the instructions before...

    Yes, I use T2Laser for the EleksDraw and EleksEgg machines. I don't have their Mill but I do have a larger CNC and my software runs that great.

    The trial is free, so you can give it a try. On the laser control screen, in the settings you must select "Configure EleksMana" and select your machine, this ensures the firmware is setup and then it will work.

  • I have the same problem, helplink text

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.