Spindle max rpm permanently (Milling cutter motor)

  • Just assembled my new Eleksmill, tested mechanics, read this forum. Tried in candle software spindle rpm settings to learn how it controls and work. Spindle got to max rpm and now it work every time as i turn on power to shield (switch on power button). Tried off/on power, reflash firmware etc. Any ideas? other mechs work fine. (didn't try laser - if it always go to max... don't want to try it this way. )

  • You might want to rephrase, not sure what you're asking...

  • 555 motor (Milling cutter motor) goes max rpm every time i turn power on.

    sorry for my bad english =(

  • Developer of T2Laser Software

    Did you configure the firmware?

  • i've tried Candle software, new version don't move axis (need new firmware?) so i updated firmware from elekscam. Used old (0.9) candle - it can move axis. Read at this forum about rpm 100-1000 on candle as 1000-10000 rpm on milling cutter motor. Tried settings 100-200-300 etc to 1000 and somewhere at this point motor got to max and cant turn off through software. I've turned all power off then turned on and motor permanently spin on full throttle. After that i've tried to reflash firmware through elekscam software, it didn't help.

  • Spindle rpm max on power up control board even if arduino board not installed.

  • Developer of T2Laser Software

    @Sheynar So it's permanently on full power, no matter what?

    Sounds like the MOSFET has shorted out, unless you know what you're doing it's probably best to replace the board.

  • RPM speed is set by gcode, I forget the exact one, but give me a bit and I'll find it.

  • Developer of T2Laser Software

    @cesnyderces It is set by the S (spindle) value, and the max is a Grbl parameter $30.

  • Ok, so first up, we need to determine what values are set for your spindle speed parameter. Type $$ in a command line interface. We're looking for line $30. If it says 255, for example, then you can set your speed between 0 and 255 and use a command between those numbers.

    Now, you should be able to turn on and off, your spindle speed, using the following command:
    m3 s255
    Sets full speed

    Or, you can vary that, by typing a lower amount
    m3 s200
    Sets partial speed

    m3 s0
    turns off the spindle

    Now, why do I mention that? Because you can edit your gcode before you send it off and make adjustments before you start. I will admit, I am a bit rusty, so I may have the commands slightly off, but I am at work, so I can't test, but I have had great success modifying my speed this way. Will test later today when I get home. But this gets you a head start on what to look for.

    Edited for clarification.

  • Developer of T2Laser Software

    @cesnyderces You are correct, that should work to test it.

  • Thanks, yah, I've been focused on 3D printing, so a tad rusty on GRBL commands.

  • Oh, before I forget, the most you'll get out of the stock setup, in terms of rpm, is about 5000 rpms. You can bump that up, by using a 24v power supply, but I would only plug that into the motor itself. Of course that means bypassing any speed control. Do not plug 24volts straight into the board. This would get you about 10,000 rpms and a bit more torque. IMO, it's often better to run as fast as you can.

  • @cesnyderces Thank you for advice, i'll try these commands. But i think something is already dead on board, because spindle turns on at power up even if arduino board is not pluged in board.

  • @cesnyderces Sad, but commands don't work. I hope i'm not a total noob on such things - i've built Prusa i3 and tuned it to work fine.

    For 24v power on spindel, i think we can read PWM data from arduino and attach small speed/voltage controller based on it.
    But that will be the other story.

    I think we can close this topic. It is hardware problem. I need new MANA board, or somehow repair existing.

  • Don't give up quite yet, let me get home and verify that I have my commands right, I'm doing this from memory. Zax was helpful in confirming that I was right, but I just want to make sure.

  • Hello sheynar
    i have just purchased the Eleksmill at Banggood
    I'm facing the same problem spindle motor or laser running permanently
    I tried the commands M3 SO in elekscamv3.1 with Eleksrom 3.8 firmware but no reaction
    in ts2 laser with gbrl 1.1 spindle off doesn't stop it either,
    I also believe it is a hardware problem,
    did you already solved it and how? new board or new mosfet ?

  • Developer of T2Laser Software

    You don't have them both connected do you?

  • hello Zax no one at the time
    first I tried Elekscam and after that i installed the ts2 lasersoftware and tried this both will not stop the laser or spindle.

  • Developer of T2Laser Software

    @Paul-den-Toom When you tested T2Laser did you install my firmware (Grbl 1.1e) and then reset the machine?

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.