Problem with servo

  • Active Member

    Got my EleksEgg today from BangGood. Assembled it, but pen lifting did not work. Every time I switch laser off from EleksMaker Evolution Desktop CAM, servo rotates itself to maximum right and buzzes. When I regulate laser power, then in smaller amount the rotation force to right is bigger when I switch laser off from CAM. What may the problem? X & Y axis works well. So far it is useless. There was also absent four M3 nuts. They missed from packing list too...

  • ElekMaker Develop Department

    Due to the EleksEgg use the different FirmWare , so before you start using servo , you can use this tool to set your board to servo mode丨-full-automactic-upgrade-and-set-param-software-download-instruction/6

    just choose EleksEgg in this software and flash it.this will help you to use servo control.

    in the furture , we will update our firmware to add servo/laser switch function .

    Best Regards,

  • Active Member

    Thanks! It works now. :)

  • ElekMaker Develop Department

    :blush: Thanks for your first support , we are just finish the newst firmware develop , now it can switch machine automatic with one single gcode line.
    we will release it with details soon~

  • @MuuSer Hello
    I read a message where you said that you did not work the "ElksEgg" machine with the software EleksCAM
    I have also tried EleksROM and I have not achieved anything.
    You can tell me how you made it work (step by step if possible).
    Thank you very much and best regards

  • Active Member

    Hello @raadel

    At first - is your computer recognises EleksEGG? Can you see the corresponding Com port in EleksCAM? If yes, then close it and run EleksROM as described above by @EleksMaker-Z. It is only for firmware updating purposes.

    Meanwhile lift your pen rotating stepper as down as possible to draw on eggs. If you want draw on spheres, you must lift it up.

    I connected pen rotating stepper to X-axis connector and egg rotating stepper to Y-axis (middle one) connector. It works also opposite way, but it is too much stress for egg as then most of drawings due EleksCAM rendering made by rotating egg, not by moving pen. And rotating egg is much complicated and works for me correctly only if I use all included three springs. (Makers - rethink please about huge friction in other side of egg linkage. Maybe use of some kind of ball bearing is wise).

    Now, if you connect to you EleksEGG via EleksCAM, in Config tab set X pulse to 16 and Y pulse to 25 and press Save. It should be work with middle sized eggs.

    And it important - first connect your EleksEGG with computer (green light will lit) and after that switch your bot on (blue light will lit).

  • The PC recognizes the machine perfectly: "find serial ports successful" and the green LED lights up. It also lights a red LED (it is near to the green on the circuit board).
    The blue LED also lights when the power is turned on.

    If I send orders to the motors using the tabs (<X- or X +> etc etc), they move perfectly but, when I load a drawing and give it start, now only the servo works, the motors do not move at all.

    Thank you so much for everything, sorry for your inconvenience.

    P.S. What is your version of EleksCAM?

  • Active Member

    I have version - downloaded from BangGood almost month ago right after ordering the EleksEGG.

  • Active Member

    for @raadel once more
    Strange - I don't see any red lights in my bot. There is green on Nano board and blye on mainboard. Maybe @EleksMaker-Z can explain, why there is red led involved in your bot...

  • Active Member

    Third time thought. :D
    I read somewhere here that maybe it helps when you start EleksCAM with administrator rights. Maybe there is issue about accessing some temporary files. It was not issue in my computer, as I allready have all admin rights in my computer, but it's worth to try as safety behavior sometimes in Windows is very strange...
    And maybe some kind of antivirus blocks something...

  • Thank you very much for everything, I will try to know why the red light is always on my plate.
    A cordial greeting

  • Active Member

    You are welcome, @raadel! :)
    If you have clarity about red led, don't hesitate share it with us also. Thanks.

  • @EleksMaker-Z
    Your software does not work......
    After a 3 hour search I was finally able to add the libusb0.dll which seems to be missing from every windows 10 machine in my possession. Why not just include the damn thing with your software. Once installed the Eleksrom v3.8 crashes on the two different machines I tried it on. providing the following error.alt text
    When using eleksCAM the outline function produces no result with any files. I have tried this on 2 different computers.

  • @MuuSer From the lack of tech support replies I'm guessing EleksMaker isn't supporting their product. I'm blown away how they don't have a simple tutorial on getting the EleksEgg up and running. Since they aren't responding I thought maybe you can help. I've got the servo to stop with the grinding noise by updating the firmware - that you suggested. The problem I have is no matter what I do I can't get the servo to lift the pen - it just seems to have a mind of its own. Did you do anything else to get it up and running?

  • Active Member

    Eleksmaker was just a hardware company. Benbox was not their product. Then Benbox abandoned their software and did not update it to support the new features that eleksmaker built into their hardware. Eleksmaker rushed Elekscam out so there would be something for purchasers to use. This is never ideal. Basically you are beta testing. Z works hard to make it better as quickly as he can and in a few months I'm sure it will be light years ahead of where it is now.

    I have a hard time feeling sorry for people searching for help here and bad talking eleksmaker. When I got my laser last year this forum didnt exist. Eleksmaker didnt talk directly to customers. My laser didnt work and there was no one to ask about it. I found @zax and the benboxlaser forum and they got my laser running. Zax software is great and gets better every month. Many of the benboxlaser guys are here and we help each other more than the manufacturers ever will. So stay, ask questions, help others, and share your successes.

  • @nottingham82 I agree with what you are saying but I think one would expect to have a product working after it is purchased. I could understand if it was being sold as a DIY but where this is marketed as something ready out of the box and not even being close to functional is pretty bad. It is a great way to NOT sell one's product.

  • Active Member

    @heedaf - only things, I can suggest if you are flashed latest firmware to EleksEGG is, that in power off mode just rotate servo hand as counter-clockwise as you can, then first connect you EleksEGG via USB to EleksCAM, then send command A1 then adjust in EleksCAM laser power slider almost to left position and then switch power on. After that it must be work.
    Maybe you need manually adjust servo hand position after power on as sometimes my EleksEgg hand lifts more than necessary when I switch it on so pen holder will fall down.

  • @MuuSer Thanks for the reply. Any power setting will just rotate the servo all the way clockwise. Very strange.

  • Active Member

  • Yep! Tried everything. Looks like they have some serious issues going on.

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.