Update GRBL to 1.1 Help



  • Hi to all! I try to update my eleksmill with eleksboard to GRBL 1.1 .....

    In the source->config file, i have "turn-on" core xy .
    If I send the code (through arduino ide)to "arduino board" i get many errors... But compile well.
    Anyone have try ?

    p.s the pin used in the eleksrom it's the same of original grbl?


  • Developer of T2Laser Software

    @Draidel You will need to make some other changes, if you don't know what you are doing I would suggest to use a pre-compiled firmware.



  • @Zax Done :D Tnx



  • @Draidel Hi, could you please explain more about how did you get it done? I'm also trying to update GRBL to 1.1. Where can I find this "pre-compiled firmware" (@Zax said). Thank you


  • Developer of T2Laser Software

    @volandomarquez T2Laser comes with many pre-compiled firmware, my default Grbl 1.1e is ideal for the EleksMaker machines. You can use T2Laser to flash them to your machine and then use other software if you like, it will only hurt my feelings a little ;)



  • @Zax

    Is it possible to get the non-compiled version from your 1.1e version? I mean the *. ino file. I have some ideas that I would like to program and test myself.

    MFG Chris ;-)


  • Developer of T2Laser Software

    @schiffer-soft My versions only have a few modifications from the original source (see below). I just change it as needed and compile the .hex, I don't keep the source for each version as there's no need.

    The default 1.1e firmware in T2Laser has the home switches defined and all my default parameters embedded, otherwise it's the normal source.

    config.h
    #define HOMING_CYCLE_0 (1<<X_AXIS)
    #define HOMING_CYCLE_1 (1<<Y_AXIS)
    #define HOMING_FORCE_SET_ORIGIN
    //#define HOMING_INIT_LOCK
    #define HOMING_FORCE_SET_ORIGIN



  • @Zax Thanks! Mine it's an Eleksmaker machine. I'll try it



  • @Zax Hi Zax - im just starting on lasers so looking for some help!
    I have downloaded T2Laser but it wont turn on my laser but will control the x/y movement.
    Laser works and will power on manually
    Control cable correctly modified.
    Im running GRBL < 1.1e how can I unpdate this?
    When I install the CH340 driver I assume thats just on the PC right??
    Any help would be great
    Cheers


  • Developer of T2Laser Software

    @AlanKWatson68 If you are using Grbl 1.1e DEFAULT it does not need to be changed. The laser is controlled by D11 (PWM) from the Nano, you can use a volt meter to check the output signal (TTL) to make sure it is wired correctly.

    The CH340 driver is just for the COM port, if you can connect then it's working fine.


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.