eleksdraw servo trouble

  • Hi,
    I just assembled the eleksdraw I bought. It seems to work perfectly, except that the pen lifting doesn't seem to work. When I start drawing, the machine moves to the start position, sets the pen down by traversing the servo to the max, and then starts drawing, never lifting the pen. In the middle of segments, when the pen should be up, it only tries to travel even more to the same direction.

    I found the solution of sending A1 before starting to draw, but that only made it so the servo no longer makes that horrible rattling sound when it continually tries to traverse too much. But it still won't lift the pen. What should I do?

  • Developer of T2Laser Software

    @karbonaatio You may have stripped out the gears on the servo, take off the pen holder and make sure the travel isn't hitting on the bracket. In T2Laser when you select the EleksDraw I change the laser max so you can't damage the machine but I don't know if EleksCAM does anything similar, I think probably not as I see a lot of people doing this.

  • Thanks for the reply. I tried T2Laser. It rotates the servo perfectly when clicking laser on, but does not reverse with laser off. I took the servo out of its mount to not let it traverse too much. The machine should have the correct firmware (Grbl 0.9i), so I'm pretty lost again.

  • Developer of T2Laser Software

    @karbonaatio I think it's already been damaged, do you have another to try?

    Unfortunately the firmware doesn't prevent over travel, that's up to the software. In T2Laser when you select EleksDraw it sets laser max at a low value to ensure no damage can occur.

  • Hello karbonaation,

    here is a picture how my penholder works.
    It came preassembled and it would not work as expected.
    The longer screw which is moved by the lever of the servo was originally on the right side.
    I moved it to the left side.
    In Elekscam you have to change the ON/OFF value under settings to 50. EleksMaker recommends 20.
    The angle of the servolever on my picture is in the OFF position.
    If your lever has another angle in the OFF position you have to unscrew it and adjust it.0_1506874347316_20171001_175556[1].jpg

  • Not working for me. No matter what I set the On/Off setting to, when I turn the laser Off, the servo attempts to move beyond it max position and starts that grinding noise.

  • Developer of T2Laser Software

    @ChrisCragg Are you sure the firmware is in servo mode?

  • @Zax I have no way of knowing. I used Select Machine button to select the drawing machine, then clicked Rst ROM, which appeared to update the firmware. Actually. Just doing what I described that I did do, fixed it!

  • FYI, I also had to rotate the servo to make it work properly. The pen was going up when it should have been going down.

  • Hello, I followed all of your above steps listed multiple times and my servo is still doing absolutely nothing. It only moves when I first plug it in... and it appears to reset to a position. Otherwise none of the buttons or things above (select machine / servo mode / on/0ff at 50 and 20 / laser on laser off) it does nothing except when i plug it in. Any help would be appreciated! Thank you

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.