Problems with spindle motor

  • Hello!

    I've build an Eleksmill a few days ago. Laser engraving works fine. But there is a main problem with getting the spindle motor to work.

    I use Elekscam and have set the software to "Eleksmill" and "spindle mode". But when I enter g-code to start the motor (f.e. m3 s100) it only starts to hum. With a little help it starts to turn very slowly - it seems that electrical power is missing. I tried to swap the poles, but only the turning-direction was effected. When I plug the spindle motor directly to the power supply of the Eleksmill it works fine! Is there something wrong with the board? Or is the problem caused by the software?

    Thanks for your help.

  • Developer of T2Laser Software

    @hami S100 is 10%, which may not be enough to start it. Does it work correctly if you use S1000? (full power with the Eleks firmware)

    If using T2Laser 255 is max power as it matches the 8-bit PWM output of the Nano.

  • When I try m3 s1000 it's still the same problem. How do I switch between laser and spindle in t2laser?

  • Developer of T2Laser Software

    @hami The laser and motor are both connected to the same D11 PWM pin on the Nano, so you don't need to switch anything in software. Unplug the laser, connect the motor or vice versa. I would also recommend using my Grbl 1.1e firmware but you can use the Eleks firmware if you prefer.


  • Thanks for your help. It works after upgrading the firmware. I've just ordered T2laser :-)

  • @hami smart move ;)

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.